Una vulnerabilidad de WhatsApp podría hackear tu iPhone con una sola llamada

Una vulnerabilidad de WhatsApp podría hackear tu iPhone con una sola llamada

Compartir

Una nueva vulnerabilidad en la seguridad de WhatsApp Messenger podría permitir a un atacante colapsar la aplicación de iOS, cerrarla automáticamente, e incluso hackear tu iPhone simplemente con una llamada.

Al parecer esta vulnerabilidad fue descubierta y reportada al equipo técnico de WhatsApp durante el mes de agosto, y por suerte ha sido corregida en la última actualización de la aplicación de iOS. Así que quizá quieras echar un vistazo en la App Store para actualizar la app de mensajería instantánea.

Te puede interesar | La publicidad en WhatsApp está a la vuelta de la esquina, eso sí, “no será invasiva”

Más detalles sobre esta vulnerabilidad de WhatsApp

Natalie Silvanovich, ingeniera de seguridad perteneciente a Google Project Zero, fue la encargada de descubrir este fallo en la aplicación de mensajería instantánea. Según ella, el bug era causado cuando un usuario recibía un paquete RTP modificado, haciendo aparecer un error que colapsa el sistema de la aplicación, que se cierra de inmediato.

Este paquete RTP malformado podía ser enviado mediante una simple solicitud de llamada en WhatsApp.

“Bug de corrupción de memoria en la implementación de vídeo conferencia no WebRTC en WhatsApp.”

Afortunadamente, tal y como indicábamos previamente, el bug ha sido parcheado por el equipo de desarrolladores de WhatsApp Messenger tanto en iOS como en Android. Los usuarios ya tienen disponible la última versión de la app, que pueden descargar e instalar desde el siguiente botón que adjuntamos a continuación:

No es la primera vez que nos encontramos con una vulnerabilidad similar en WhatsApp. De hecho, en agosto se descubrió que era posible que un atacante cambiara tanto el contenido como el emisor de un mensaje después de haberlo recibido en una conversación de chat.

Fuente | The Register