La nueva vulnerabilidad Spectre solo afectará a tu Mac… si tienes instalado...

La nueva vulnerabilidad Spectre solo afectará a tu Mac… si tienes instalado Windows

Con macOS estarás a salvo, si tiene sWindows actualiza cuanto antes.

Compartir

MacBook Air 2018 portada 1

Hace un tiempo os hablamos de Spectre y Metdown, dos vulnerabilidades encontradas en el diseño de los chips de Intel y ARM que afectaban a casi todos los dispositivos fabricados en la última década. Tanto Microsoft como Apple actualizaron sus sistemas operativos con parches de seguridad, sin embargo se acaba de descubrir un nuevo exploit.

Este fallo grave de seguridad afortunadamente solo afecta a dispositivos que utilicen Windows como sistema operativo, por lo que tu Mac está a salvo, siempre y cuando no tengas Windows instalado en una partición. El error se acaba de desvelar en al con gerencia de seguridad de Black Hat, casi un año después de que los investigadores de Bitdefender, la empresa que descubrió este fallo, informaran a Intel sobre él.

Parece ser que Microsoft ya lo ha corregido

Bitdefender desveló este error de seguridad en conjunto con Microsoft hoy en la conferencia de seguridad de Black Hat, casi un año después de que los investigadores de Bitdefender informaran sobre él. Microsoft en teoría ha lanzado el parche de seguridad, aunque la compañía no lo ha anunciado.

“Cada máquina que utilice los procesadores Intel más nuevos que aprovechan speculative execution y ejecutan Windows se ve afectada, incluidos los servidores y los ordenadores portátiles”

El fallo afecta a una instrucción del sistema en Windows de 64 bits llamada SWAPGS, un conjunto de instrucciones a nivel de núcleo introducido junto con los procesadores Ivy Bridge de Intel en 2012. Un atacante con conocimiento podría recoger lo que está haciendo el núcleo del sistema y, por tanto, conseguir una gran cantidad de información que debería ser secreta, como contraseñas, claves, tokens de inicio de sesión y otros datos.

spectre

Ya que este tipo de instrucciones SWAPGS solo se usan en Windows, los usuarios de macOS estamos a salvo siempre que no utilicemos Windows. Afortunadamente este error ya se ha resuelto, pero recuerda que debes actualizar siempre tus sistemas operativos para evitar este tipo de errores de seguridad.