Esto es importante: actualiza WhatsApp a la última versión disponible

    De no actualizar WhatsApp para iOS estás exponiendo tu terminal por culpa de varias vulnerabilidades detectadas.

    Usuarios del iPhone, si todavía no habéis actualizado WhatsApp a su última versión hacedlo lo antes posible. «The Indian Computer Emergency Response Team» ha detectado una serie de vulnerabilidades en la aplicación de mensajería propiedad de Facebook que permiten realizar un acceso remoto a los terminales, sobrepasando las restricciones de seguridad e incluso ejecutar código en el equipo objetivo.

    WhatsApp logo
    Mantener WhatsApp actualizado es la mejor forma de estar a salvo.

    Según apuntan desde el sitio web del CERT-In, la importancia de este problema ha sido ratificada como «alta», y afecta a WhatsApp y a WhatsApp Business en sus versiones previas a 2.20.111.

    La primera vulnerabilidad, llamada «Improper Access Control Vulnerability» ha sido detectada en la prestación «pantalla de bloqueo» de WhatsApp, donde un atacante puede ejecutar un exploit usando Siri para comunicarse incluso después de bloquear el terminal. Un ataque exitoso por esta vía puede sobrepasar las restricciones de seguridad de la app.

    La segunda vulnerabilidad detectada, titulada en este caso «Use-After-Free-Vulnerability», ha sido encontrada en un error de registro en las librerías de WhatsApp y WhatsApp Business, debido a un fallo conocido como «error tras uso libre».

    Un atacante puede aprovechar esta vulnerabilidad para enviar stickers animados a un usuario objetivo mientras realiza una videollamada, resultando en varios eventos sucediendo al mismo tiempo en secuencia.

    Un ataque efectivo por esta vía puede llevar a una corrupción de la memoria, la negación de condiciones de servicio y la ejecución de un código remoto, según informan.

    ¿Cómo evitar que suceda todo esto? Actualizando la aplicación. Si no estas seguro si cuentas o no con la última versión de WhatsApp en tu iPhone dirígete a la App Store, busca la app y asegúrate de que no tiene ninguna actualización pendiente. En el caso de que la tenga, no dudes en realizarla, pues de lo contrario podría suponer una exposición innecesaria a estas vulnerabilidades.